aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 15:23:49 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 15:23:59 +0100
commit47fc4850e42f4d1e4d76189431863124f7885576 (patch)
tree7691b73ea369cebd7f90b7ac89d741499e5122db /gnu
parentb4a689bcfb8a062786e415ae71233c52fdbffa79 (diff)
downloadguix-47fc4850e42f4d1e4d76189431863124f7885576.tar
guix-47fc4850e42f4d1e4d76189431863124f7885576.tar.gz
gnu: Add go-github-com-whyrusleeping-chunker.
* gnu/packages/golang-web.scm (go-github-com-whyrusleeping-chunker): New variable. Change-Id: Ib89feab1054e71a1bb603659c4e93c1d8256dc8f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index cfb58ce115..a8eee0c214 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2848,6 +2848,31 @@ encoding library for the MessagePack, CBOR, JSON and the Binc formats.")
replacement for native @code{net/http} module.")
(license license:expat)))
+(define-public go-github-com-whyrusleeping-chunker
+ (package
+ (name "go-github-com-whyrusleeping-chunker")
+ (version "0.0.0-20181014151217-fe64bd25879f")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whyrusleeping/chunker")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13q4flp9iwwyi0izqar786h42713rf3m22qlvg0masbmdi69qjr2"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/whyrusleeping/chunker"))
+ (home-page "https://github.com/whyrusleeping/chunker")
+ (synopsis "Implementation of Content Defined Chunking in Golang")
+ (description
+ "Package chunker implements @acronym{Content Defined Chunking,CDC} based
+on a rolling Rabin Checksum. This package provides a modified fork of
+https://github.com/restic/restic project.")
+ (license license:bsd-2)))
+
(define-public go-github-com-whyrusleeping-json-filter
(let ((commit "ff25329a9528f01c5175414f16cc0a6a162a5b8b")
(revision "0"))