aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:10:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:16 +0200
commit5138207b6a58d7cb8b1e18a373bc49229f1f0aff (patch)
treefa7d3c58640f8a99ad8a534afd49444507a96ced /gnu
parent850495cc2e9d32ac3a24ac47eba9d38bb202628e (diff)
downloadguix-5138207b6a58d7cb8b1e18a373bc49229f1f0aff.tar
guix-5138207b6a58d7cb8b1e18a373bc49229f1f0aff.tar.gz
gnu: Add texlive-ccool.
* gnu/packages/tex.scm (texlive-ccool): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8d4de06b61..6753eff826 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2200,6 +2200,32 @@ font family. The files support OT1, T1, TS1, and Concrete mathematics
including AMS fonts (Ulrik Vieth's @code{concmath}).")
(license license:lppl)))
+(define-public texlive-ccool
+ (package
+ (name "texlive-ccool")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ccool/" "source/latex/ccool/"
+ "tex/latex/ccool/")
+ (base32
+ "17xkwd8mrvl751rn6zvxaznac27rpvmi53rq8nwwlp6j1bdnaj94")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ccool")
+ (synopsis "Key-value document command parser")
+ (description
+ "This package provides a key-value interface, @code{\\Ccool}, on top of
+@code{xparse}'s document command parser. Global options control input
+processing and its expansion. By default, they are set to meet likely
+requirements, depending on context: the selected language, and which of text
+and math mode is active. These options can be overridden inline. Polymorphic
+commands can be generated by parameterizing the keys (for instance, one
+parameter value for style, another for a property). User input to
+@code{\\Ccool} can optionally be serialized. This can useful for typesetting
+documents sharing the same notation.")
+ (license license:lppl1.3c)))
+
(define-public texlive-chronosys
(package
(name "texlive-chronosys")