aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:10:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:16 +0200
commit850495cc2e9d32ac3a24ac47eba9d38bb202628e (patch)
tree2f2a1bb1186160aac882d75b98e685a068263693 /gnu
parent7e335b9ad20ad1aa8699e51d1d727a5120294f9d (diff)
downloadguix-850495cc2e9d32ac3a24ac47eba9d38bb202628e.tar
guix-850495cc2e9d32ac3a24ac47eba9d38bb202628e.tar.gz
gnu: Add texlive-ccfonts.
* gnu/packages/tex.scm (texlive-ccfonts): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 51b2f5d4a5..8d4de06b61 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2178,6 +2178,28 @@ macros can also be used in the @code{tikzpicture} environment to annotate or
modify a diagram.")
(license license:lppl1.3+)))
+(define-public texlive-ccfonts
+ (package
+ (name "texlive-ccfonts")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ccfonts/" "source/latex/ccfonts/"
+ "tex/latex/ccfonts/")
+ (base32
+ "1r319fv1n9fsnnycza4z1j23dp03fww98a03hmcapkyr9pp9lvv4")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:tex-format "latex"))
+ (home-page "https://ctan.org/pkg/ccfonts")
+ (synopsis "Support for Concrete text and math fonts in LaTeX")
+ (description
+ "This package provides LaTeX font definition files for the Concrete fonts
+and a LaTeX package for typesetting documents using Concrete as the default
+font family. The files support OT1, T1, TS1, and Concrete mathematics
+including AMS fonts (Ulrik Vieth's @code{concmath}).")
+ (license license:lppl)))
+
(define-public texlive-chronosys
(package
(name "texlive-chronosys")