aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:55:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:10 +0200
commit4649e211c2ef7a736290430fd1fad2e046be112d (patch)
tree64911da110bf1bdb4327f11e9ec9237d88508abd /gnu
parentffcd953c3745aba9604837b01efb83a627372496 (diff)
downloadguix-4649e211c2ef7a736290430fd1fad2e046be112d.tar
guix-4649e211c2ef7a736290430fd1fad2e046be112d.tar.gz
gnu: Add texlive-tqft.
* gnu/packages/tex.scm (texlive-tqft): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3b0c7db5e1..f879250ce3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5559,6 +5559,27 @@ tone values. Currently, unt's model is implemented. Support for more models
is planned.")
(license license:asl2.0)))
+(define-public texlive-tqft
+ (package
+ (name "texlive-tqft")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tqft/" "source/latex/tqft/"
+ "tex/latex/tqft/")
+ (base32
+ "08lykpnw0hifhmh96pb7s3dd8sbzmz3gqyrwy5ann9fqxxjczf2d")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tqft")
+ (synopsis "Drawing TQFT diagrams with TikZ/PGF")
+ (description
+ "The package defines some node shapes useful for drawing TQFT diagrams
+with TikZ/PGF. That is, it defines highly customisable shapes that look like
+cobordisms between circles, such as those used in TQFT and other mathematical
+diagrams.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")