aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-06 22:27:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 11:20:19 +0100
commit458704757143224dcc4bd650a5092286cca28b13 (patch)
tree83ce09ebcc229464980fe207211a030b70d40a09 /gnu
parentc7cf66fb4025afb8309a968d8bc4bdf87ed9c666 (diff)
downloadguix-458704757143224dcc4bd650a5092286cca28b13.tar
guix-458704757143224dcc4bd650a5092286cca28b13.tar.gz
gnu: Add go-chroma.
* gnu/packages/golang-xyz.scm (go-chroma): New variable. Change-Id: Idb13913bc51ac37fb9fa8ce315aebdc014e53b10
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dfaedd604a..7f40c856dc 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5101,6 +5101,40 @@ values.")
;;; Executables:
;;;
+(define-public go-chroma
+ (package
+ (name "go-chroma")
+ (version "2.14.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/chroma")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qgr4gywjks869sc85wb8nby612b8wvsa1dwpsbanjsljq7wq7mp"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.19
+ #:install-source? #f
+ #:import-path "github.com/alecthomas/chroma/cmd/chroma"))
+ (native-inputs
+ (list go-github-com-alecthomas-assert-v2
+ go-github-com-alecthomas-chroma-v2
+ go-github-com-alecthomas-kong
+ go-github-com-mattn-go-colorable
+ go-github-com-mattn-go-isatty))
+ (home-page "https://github.com/alecthomas/chroma")
+ (synopsis "General purpose syntax highlighter in pure Golang")
+ (description
+ (string-append (package-description go-github-com-alecthomas-chroma-v2)
+ " This package provides an command line interface (CLI)
+tool."))
+ (license license:asl2.0)))
+
(define-public go-hclogvet
(package
(inherit go-github-com-hashicorp-go-hclog)