aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-06 09:52:05 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 11:20:19 +0100
commitc7cf66fb4025afb8309a968d8bc4bdf87ed9c666 (patch)
tree3d14c139f700b6fcbfae07e29a9b7bb0ede0f9ee /gnu
parent404d3c7776a773359ed3f8d3f0a2baa4075ec2f3 (diff)
downloadguix-c7cf66fb4025afb8309a968d8bc4bdf87ed9c666.tar
guix-c7cf66fb4025afb8309a968d8bc4bdf87ed9c666.tar.gz
gnu: Add go-github-com-alecthomas-kong.
* gnu/packages/golang-xyz.scm (go-github-com-alecthomas-kong): New variable. Change-Id: I92218bd2cf6c186e63812dd83655686bb7a7f97a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 86964c47b9..dfaedd604a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -587,6 +587,37 @@ be stripped.")
(native-inputs
(list go-github-com-stretchr-testify))))
+(define-public go-github-com-alecthomas-kong
+ (package
+ (name "go-github-com-alecthomas-kong")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/kong")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a9arf30h84ll8k612jh50c3vjmvdfj6i7dbvfnw3dalm6dn2aan"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; One test failed when set to go-1.18 o lower, see
+ ;; <https://github.com/alecthomas/kong/issues/437>
+ #:go go-1.19
+ #:import-path "github.com/alecthomas/kong"))
+ (native-inputs
+ (list go-github-com-alecthomas-assert-v2))
+ (propagated-inputs
+ (list go-github-com-alecthomas-repr))
+ (home-page "https://github.com/alecthomas/kong")
+ (synopsis "Command-line parser for Golang")
+ (description
+ "Package kong aims to support arbitrarily complex command-line structures
+with as little developer effort as possible.")
+ (license license:expat)))
+
(define-public go-github-com-alecthomas-participle-v2
(package
(name "go-github-com-alecthomas-participle-v2")