aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 21:17:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:02 +0100
commit27a387a1522ce35a4f863982c9dfa369f84fff43 (patch)
treed1690df70b3afce3aecc618dda1eb0e2c950aa10 /gnu
parenta1cf6f78fd511609f192660945e24538b58a460c (diff)
downloadguix-27a387a1522ce35a4f863982c9dfa369f84fff43.tar
guix-27a387a1522ce35a4f863982c9dfa369f84fff43.tar.gz
gnu: go-github-com-prometheus-common: Update to 0.55.0.
* gnu/packages/golang.scm (go-github-com-prometheus-common): Update to 0.55.0. [propagated-inputs]: Remove go-github-com-golang-protobuf and go-github-com-matttproud-golang-protobuf-extensions-v2; add go-github-com-alecthomas-kingpin-v2, go-github-com-go-kit-log, go-github-com-google-go-cmp, go-github-com-julienschmidt-httprouter, go-github-com-munnerz-goautoneg, go-github-com-mwitkow-go-conntrack, go-golang-org-x-net, go-golang-org-x-oauth2, go-google-golang-org-protobuf, and go-gopkg-in-yaml-v2. [native-inputs]: Add go-github-com-stretchr-testify. Change-Id: Ia4550bffb8f49a764e058e4f98a91d9e7dc96021
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 518bda7299..d60ae45722 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7352,7 +7352,7 @@ formatting information, rather than the current locale name.")
(define-public go-github-com-prometheus-common
(package
(name "go-github-com-prometheus-common")
- (version "0.45.0")
+ (version "0.55.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7361,7 +7361,7 @@ formatting information, rather than the current locale name.")
(file-name (git-file-name name version))
(sha256
(base32
- "006y6mlxglr2xzmdqxl5bwh899whfx1prcgjai7qhhs5ys5dspy5"))
+ "0bsbxil7qz8rhckhv0844nmn38g7i7347cjv5m6na47hbdpi0rqh"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -7380,10 +7380,20 @@ formatting information, rather than the current locale name.")
(modify-phases %standard-phases
;; Source-only package
(delete 'build))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
(propagated-inputs
- (list go-github-com-golang-protobuf
- go-github-com-matttproud-golang-protobuf-extensions-v2
- go-github-com-prometheus-client-model))
+ (list go-github-com-alecthomas-kingpin-v2
+ go-github-com-go-kit-log
+ go-github-com-google-go-cmp
+ go-github-com-julienschmidt-httprouter
+ go-github-com-munnerz-goautoneg
+ go-github-com-mwitkow-go-conntrack
+ go-github-com-prometheus-client-model
+ go-golang-org-x-net
+ go-golang-org-x-oauth2
+ go-google-golang-org-protobuf
+ go-gopkg-in-yaml-v2))
(synopsis "Prometheus metrics")
(description "This package provides tools for reading and writing
Prometheus metrics.")