aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 20:51:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:01 +0100
commita1cf6f78fd511609f192660945e24538b58a460c (patch)
tree7fd0799e39efc0ac598a86658e8f8a26599ed5d0 /gnu
parent76f1290a388a7f525458b0f37a9e14aa396f302d (diff)
downloadguix-a1cf6f78fd511609f192660945e24538b58a460c.tar
guix-a1cf6f78fd511609f192660945e24538b58a460c.tar.gz
gnu: go-github-com-prometheus-common: Remove submodules.
Removing Golang submodules which need to be packed as separate packages. Each of them has it's own dependencies defined in go.mod and causing cycling with other packages if distributed with go-github-com-prometheus-common. * gnu/packages/golang.scm (go-github-com-prometheus-common) [snippet]: Remove submodules. Change-Id: Ic586cb6b653fd932dad402d700a0c3addd542d99
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2bf4da8eba..518bda7299 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7361,7 +7361,17 @@ formatting information, rather than the current locale name.")
(file-name (git-file-name name version))
(sha256
(base32
- "006y6mlxglr2xzmdqxl5bwh899whfx1prcgjai7qhhs5ys5dspy5"))))
+ "006y6mlxglr2xzmdqxl5bwh899whfx1prcgjai7qhhs5ys5dspy5"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Submodules with their own go.mod files and packed as
+ ;; separated packages:
+ ;;
+ ;; - github.com/prometheus/common/assets
+ ;; - github.com/prometheus/common/sigv4
+ (for-each delete-file-recursively
+ (list "assets" "sigv4"))))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/prometheus/common"