aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2024-09-17 20:16:51 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-28 00:20:19 +0200
commitf6752fd6e937f07511782f31478ddc0c7f545b86 (patch)
treeb07e4e82c9df83685e1c4960d209ea9bdb4816d0 /gnu/packages
parent44aba54ed3b8ad1066528db09ba3acbc832011e8 (diff)
downloadguix-f6752fd6e937f07511782f31478ddc0c7f545b86.tar
guix-f6752fd6e937f07511782f31478ddc0c7f545b86.tar.gz
gnu: aws-c-common: Update to 0.9.27.
* gnu/packages/c.scm (aws-c-common): Update to 0.9.27. [arguments]: Disable parallel tests. [supported-systems]: Add armhf-linux and aarch64-linux. Change-Id: I66ddf9ed03f8ead70aa1c86792dd4aa8782ac59e
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/c.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 62234d3c9a..43c837d251 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -977,7 +977,7 @@ C programming language.")
(package
(name "aws-c-common")
;; Update only when updating aws-crt-cpp.
- (version "0.6.20")
+ (version "0.9.27")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -986,13 +986,15 @@ C programming language.")
(file-name (git-file-name name version))
(sha256
(base32
- "089grcj58n4xs41kmnpaqpwsalcisjbqqb5yqahxxyfx2lf1j9c9"))))
+ "1wzlxvcwr4s31c4q8nyj66x3za9s01xzq47ap2jwvr61c93pxcam"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
+ '(#:parallel-tests? #f
+ #:configure-flags
'("-DBUILD_SHARED_LIBS=ON")))
+ (supported-systems '("armhf-linux" "aarch64-linux"
+ "i686-linux" "x86_64-linux"))
(synopsis "Amazon Web Services core C library")
- (supported-systems '("i686-linux" "x86_64-linux"))
(description
"This library provides common C99 primitives, configuration, data
structures, and error handling for the @acronym{AWS,Amazon Web Services} SDK.")