aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2024-09-17 20:16:50 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-28 00:20:19 +0200
commit44aba54ed3b8ad1066528db09ba3acbc832011e8 (patch)
tree80b2e77f851d9f6de77ee6b09fed19036e22a5bf /gnu/packages
parenteb4b4f3e320e014d0e31ec904f6acb8a55aad277 (diff)
downloadguix-44aba54ed3b8ad1066528db09ba3acbc832011e8.tar
guix-44aba54ed3b8ad1066528db09ba3acbc832011e8.tar.gz
gnu: s2n: Update to 1.5.1.
* gnu/packages/tls.scm (s2n): Update to 1.5.1. [arguments]: Re-enable warnings as errors. [supported-systems]: Restrict to 64-bit systems. Change-Id: I09d690c96789961473c846eb8174ddc8a2b1ad4e
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tls.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a9017df698..fcad5401d5 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1147,7 +1147,7 @@ derived from Mozilla's collection.")
(package
(name "s2n")
;; Update only when updating aws-crt-cpp.
- (version "1.3.10")
+ (version "1.5.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1156,17 +1156,13 @@ derived from Mozilla's collection.")
(file-name (git-file-name name version))
(sha256
(base32
- "15fr6zwglw74x5qd090752kqn7n3cyi4gmz94ip45g3hflschxd3"))))
+ "0cw8f846zvjgdwaqadnhdb0cxksx4jd9x4nan9x02xz2w5hcqw04"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON"
- ;; Remove in next update; see https://github.com/aws/s2n-tls/pull/3108
- ;; Building with 'Werror' results in compilation error (even building
- ;; with gcc) when replacing the aws-lc input with openssl.
- "-DUNSAFE_TREAT_WARNINGS_AS_ERRORS=OFF")))
+ '("-DBUILD_SHARED_LIBS=ON")))
(propagated-inputs (list aws-lc))
- (supported-systems '("x86_64-linux"))
+ (supported-systems '("aarch64-linux" "x86_64-linux"))
(synopsis "SSL/TLS implementation in C99")
(description
"This library provides a C99 implementation of SSL/TLS. It is designed to