aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:23:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:39 +0200
commitecb349331a93bdb6fd32e8cbdd6828cdfd510544 (patch)
tree243a9df7e2f8aea6839bd3e8c996c2f3d233d292 /gnu/packages
parentc6949b4933c323b9cfc79d0f4dc08f493c658c49 (diff)
downloadguix-ecb349331a93bdb6fd32e8cbdd6828cdfd510544.tar
guix-ecb349331a93bdb6fd32e8cbdd6828cdfd510544.tar.gz
gnu: Add texlive-pst-magneticfield.
* gnu/packages/tex.scm (texlive-pst-magneticfield): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1cf1cf519f..16f0beb81d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33426,6 +33426,28 @@ used to model the morphology of a variety of organisms or fractals like the
Kochflake or Hilbert curve.")
(license license:lppl)))
+(define-public texlive-pst-magneticfield
+ (package
+ (name "texlive-pst-magneticfield")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-magneticfield/"
+ "dvips/pst-magneticfield/"
+ "tex/generic/pst-magneticfield/"
+ "tex/latex/pst-magneticfield/")
+ (base32
+ "0gxz7yfj16b23lwn5pq68r8yb6klm7xhmq5m0addmrq1dvb3id5n")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-magneticfield")
+ (synopsis "Plotting a magnetic field with PSTricks")
+ (description
+ "@code{pst-magneticfield} is a PSTricks related package to draw the
+magnetic field lines of Helmholtz coils in a two or three dimensional view.
+There are several parameters to create a different output.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")