aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:23:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:39 +0200
commitc6949b4933c323b9cfc79d0f4dc08f493c658c49 (patch)
tree25ccee1304938af80f498c88a46c28d3f641d8a1 /gnu/packages
parenta3ec9f83784f949da31614a119dc42b33f9330a5 (diff)
downloadguix-c6949b4933c323b9cfc79d0f4dc08f493c658c49.tar
guix-c6949b4933c323b9cfc79d0f4dc08f493c658c49.tar.gz
gnu: Add texlive-pst-lsystem.
* gnu/packages/tex.scm (texlive-pst-lsystem): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9b1f3a6d9f..1cf1cf519f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33403,6 +33403,29 @@ a remarkable range of effects.")
effects on characters and PSTricks graphics, like lines, curves, plots, ...")
(license license:lppl)))
+(define-public texlive-pst-lsystem
+ (package
+ (name "texlive-pst-lsystem")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-lsystem/"
+ "dvips/pst-lsystem/"
+ "tex/generic/pst-lsystem/"
+ "tex/latex/pst-lsystem/")
+ (base32
+ "1k3krdcfqa5cyzaq0jp8dzil6arfvs5ah2mp87460pl2wvfza0lr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-lsystem")
+ (synopsis "Create images based on a L-system")
+ (description
+ "@code{pst-lsystem} is a PSTricks based package for creating images based
+on a L-system. A L-system (Lindenmayer system) is a set of rules which can be
+used to model the morphology of a variety of organisms or fractals like the
+Kochflake or Hilbert curve.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")