aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-20 23:12:50 +0100
committerAndrew Tropin <andrew@trop.in>2024-05-30 18:23:48 +0400
commitb12ab191b8cd2ca26bb03020939decad7c23a366 (patch)
tree1af26c68a6c1ef3ac01147c6db7078e4666fa50a /gnu/packages
parentfc08d71486cb7fe3aa409984377cd510515383a8 (diff)
downloadguix-b12ab191b8cd2ca26bb03020939decad7c23a366.tar
guix-b12ab191b8cd2ca26bb03020939decad7c23a366.tar.gz
gnu: Add python-geopack.
* gnu/packages/geo.scm (python-geopack): New variable. Change-Id: I674b09030684dd0d9f94b4b87cf96aeea983ee89 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/geo.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c9152fb4f8..69e7b58677 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -959,6 +959,32 @@ systems and integrates readily with other Python GIS packages such as
pyproj, Rtree, and Shapely.")
(license license:bsd-3)))
+(define-public python-geopack
+ (package
+ (name "python-geopack")
+ (version "1.0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "geopack" version))
+ (sha256
+ (base32 "0mryjp7m4h99qlpvnn40s81sygr73qcv8rkmjp9pcli1gz829kjf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; XXX Reported upstream <https://github.com/tsssss/geopack/issues/21>.
+ #:tests? #f))
+ (native-inputs
+ (list python-pytest))
+ (propagated-inputs
+ (list python-numpy python-scipy))
+ (home-page "https://github.com/tsssss/geopack")
+ (synopsis "Python version of geopack and Tsyganenko models")
+ (description
+ "Python version of geopack and Tsyganenko models, compatible with
+@code{geopack05} and @code{geopack08}.")
+ (license license:expat)))
+
(define-public python-geopandas
(package
(name "python-geopandas")