aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-20 23:12:49 +0100
committerAndrew Tropin <andrew@trop.in>2024-05-30 18:23:47 +0400
commitfc08d71486cb7fe3aa409984377cd510515383a8 (patch)
tree4374286994bc97da13bf0433f5f566d7f45f940c /gnu/packages
parentea221e3ede70a56ae24c7254647c183ef234644d (diff)
downloadguix-fc08d71486cb7fe3aa409984377cd510515383a8.tar
guix-fc08d71486cb7fe3aa409984377cd510515383a8.tar.gz
gnu: Add python-viresclient.
* gnu/packages/astronomy.scm (python-viresclient): New variable. Change-Id: I690a6d8f1fc80dde1605f50d09f540d556fa881b Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 13387c3349..122be3b260 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5214,6 +5214,37 @@ astronomical images, especially when there is no WCS information available.")
orbit around the Earth.")
(license license:expat)))
+(define-public python-viresclient
+ (package
+ (name "python-viresclient")
+ (version "0.11.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "viresclient" version))
+ (sha256
+ (base32 "1npn5ka0cflvl6ngf5b08z59dh79hnyh5v2z4sf0872q9zkwmjjw"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-flit-core python-pytest))
+ (propagated-inputs
+ (list python-cdflib
+ python-jinja2
+ python-netcdf4
+ python-pandas
+ python-requests
+ python-tables
+ python-tqdm
+ python-xarray))
+ (home-page "https://viresclient.readthedocs.io/en/latest/")
+ (synopsis "Python client for interacting with a VirES server")
+ (description
+ "This package provides a Python client for interacting with a
+@code{VirES} server, of which there are two: VirES for
+@url{https://vires.services, Swarm} and VirES for
+@url{https://aeolus.services, Aeolus}")
+ (license license:expat)))
+
(define-public python-wiimatch
(package
(name "python-wiimatch")