aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-02-03 16:11:58 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-11 17:28:59 +0100
commitad2c1833a01394acf899818c75e987d758e28f79 (patch)
treec4cfa9cc325e86cff56f20beafa9c858532b1668 /gnu/packages
parent8b679328512fbf5ca4c50c446884fc6069fdb589 (diff)
downloadguix-ad2c1833a01394acf899818c75e987d758e28f79.tar
guix-ad2c1833a01394acf899818c75e987d758e28f79.tar.gz
gnu: Add ocaml-toml.
* gnu/packages/ocaml.scm (ocaml-toml): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu> Change-Id: Ia3ec7d0261cd6950f1a73641fc65b3ef7ce98f24
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2e888272bd..3a8c93cd9b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2348,6 +2348,29 @@ and RFC 3339 formats in OCaml.")
(home-page "https://github.com/ocaml-community/ISO8601.ml")
(license license:expat)))
+(define-public ocaml-toml
+ (package
+ (name "ocaml-toml")
+ (version "7.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-toml/To.ml")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z2873mj3i6h9cg8zlkipcjab8jympa4c4avhk4l04755qzphkds"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-base ocaml-mdx ocaml-menhir ocaml-iso8601))
+ (synopsis "TOML library for OCaml")
+ (description
+ "This package provides an OCaml library for interacting with files
+in the @acronym{TOML, Tom's Obvious Minimal Language} format. Specifically,
+it provides a parser, a serializer, and a pretty printer.")
+ (home-page "https://github.com/ocaml-toml/To.ml")
+ (license license:expat)))
+
(define-public ocaml-topkg
(package
(name "ocaml-topkg")