aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-02-03 16:11:57 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-11 17:26:37 +0100
commit8b679328512fbf5ca4c50c446884fc6069fdb589 (patch)
tree49e5063c97ae8cdb63363a37fe673719f55e912b /gnu/packages
parenta8930124d50faeef4a0460488a30be82bbdb192e (diff)
downloadguix-8b679328512fbf5ca4c50c446884fc6069fdb589.tar
guix-8b679328512fbf5ca4c50c446884fc6069fdb589.tar.gz
gnu: Add ocaml-iso8601
* gnu/packages/ocaml.scm (ocaml-iso8601): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu> Change-Id: I9463d6f6e3f8ffe43a0cfb1c95edea42fc770323
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9c0fab1c38..2e888272bd 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2023 Csepp <raingloom@riseup.net>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023 Arnaud DABY-SEESARAM <ds-ac@nanein.fr>
+;;; Copyright © 2024 Sören Tempel <soeren@soeren-tempel.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2326,6 +2327,27 @@ defined in this library.")
#:ocaml ,ocaml-5.0
#:findlib ,ocaml5.0-findlib))))
+(define-public ocaml-iso8601
+ (package
+ (name "ocaml-iso8601")
+ (version "0.2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-community/ISO8601.ml")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nzadswspizi7s6sf67icn2xgc3w150x8vdg5nk1mjrm2s98n6d3"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-stdlib-shims ocaml-core-unix ocaml-ounit))
+ (synopsis "Parser and printer for date-times in ISO8601")
+ (description "This package allows parsing of dates that follow the ISO 8601
+and RFC 3339 formats in OCaml.")
+ (home-page "https://github.com/ocaml-community/ISO8601.ml")
+ (license license:expat)))
+
(define-public ocaml-topkg
(package
(name "ocaml-topkg")