aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-07-20 18:33:50 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-22 23:13:42 +0100
commit2053b36e5c4b187357443ded7fcd03139507a23e (patch)
tree881d8ab4c9f5979b1fe682860bc2ab7fff1146fb /gnu/packages
parent9bf27e5f4235241b84cfcc112c43a8d39a5fd25e (diff)
downloadguix-2053b36e5c4b187357443ded7fcd03139507a23e.tar
guix-2053b36e5c4b187357443ded7fcd03139507a23e.tar.gz
gnu: Add go-github-com-ipfs-go-ipfs-blocksutil.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-blocksutil): New variable. Change-Id: I64c8f6a6d2337b40fa24e478ba49a590abced8ec Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ipfs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 82d8914250..08f88ef3e4 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -72,6 +72,36 @@ by a @acronym{Content Identifiers,CID}. The CID contains the multihash
corresponding to the block.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipfs-blocksutil
+ ;; Use the latest commit from the "master" branch to fix the build with
+ ;; go-1.21, see <https://github.com/ipfs/go-ipfs-blocksutil/issues/25>.
+ (let ((commit "ce0497f5ee55c479db98905aec8ff56c27aad2a2")
+ (revision "0"))
+ (package
+ (name "go-github-com-ipfs-go-ipfs-blocksutil")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-blocksutil")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ya6376wphp51rv48nmv4jw3x0mf6ym5yx1650fbkp5l5crqpdb8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipfs-blocksutil"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-block-format))
+ (home-page "https://github.com/ipfs/go-ipfs-blocksutil")
+ (synopsis "Utility functions for working with IPFS blocks")
+ (description
+ "This package provides an utility functions for working with
+@url{https://github.com/ipfs/go-block-format, IPFS blocks}.")
+ (license license:expat))))
+
(define-public go-github-com-ipfs-go-cid
(package
(name "go-github-com-ipfs-go-cid")