aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ipfs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 82d8914250..08f88ef3e4 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -72,6 +72,36 @@ by a @acronym{Content Identifiers,CID}. The CID contains the multihash
corresponding to the block.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipfs-blocksutil
+ ;; Use the latest commit from the "master" branch to fix the build with
+ ;; go-1.21, see <https://github.com/ipfs/go-ipfs-blocksutil/issues/25>.
+ (let ((commit "ce0497f5ee55c479db98905aec8ff56c27aad2a2")
+ (revision "0"))
+ (package
+ (name "go-github-com-ipfs-go-ipfs-blocksutil")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-blocksutil")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ya6376wphp51rv48nmv4jw3x0mf6ym5yx1650fbkp5l5crqpdb8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipfs-blocksutil"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-block-format))
+ (home-page "https://github.com/ipfs/go-ipfs-blocksutil")
+ (synopsis "Utility functions for working with IPFS blocks")
+ (description
+ "This package provides an utility functions for working with
+@url{https://github.com/ipfs/go-block-format, IPFS blocks}.")
+ (license license:expat))))
+
(define-public go-github-com-ipfs-go-cid
(package
(name "go-github-com-ipfs-go-cid")