aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 16:34:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:52 +0200
commit199201b11c5bf95b15414723c85070d8552ab7b2 (patch)
tree7efff3b12fe837644d33d689ff861d38a2f7657c /gnu/packages
parentc7747de83e6327cd5eb21854ba2b57e107e13e63 (diff)
downloadguix-199201b11c5bf95b15414723c85070d8552ab7b2.tar
guix-199201b11c5bf95b15414723c85070d8552ab7b2.tar.gz
gnu: texlive-latex-translations -> texlive-translations.
* gnu/packages/tex.scm (texlive-translations): New variable. (texlive-latex-translations): Deprecate variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9318456a88..79dbf93384 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11542,15 +11542,21 @@ are valid as arguments for the macros. The package may be used under
LaTeX and plain TeX.")
(license (license:fsf-free "file:/binhex.dtx"))))
-(define-public texlive-latex-translations
+(define-public texlive-translations
(package
- (inherit (simple-texlive-package
- "texlive-latex-translations"
+ (name "texlive-translations")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
(list "doc/latex/translations/"
"tex/latex/translations/")
- (base32 "0vl7ckpbkjvz3a5snzppb96ncwgmhpwb2p6cg30grfyn421kap3v")
- #:trivial? #t))
+ (base32
+ "0vl7ckpbkjvz3a5snzppb96ncwgmhpwb2p6cg30grfyn421kap3v")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-etoolbox
+ texlive-pdftexcmds))
(home-page "https://ctan.org/pkg/translations")
(synopsis "Internationalisation of LaTeX2e packages")
(description
@@ -11565,6 +11571,8 @@ Danish and Portuguese from babel or polyglossia if either is in use in the
document.")
(license license:lppl1.3c+)))
+(define-deprecated-package texlive-latex-translations texlive-translations)
+
(define-public texlive-translator
(package
(inherit (simple-texlive-package