aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 16:27:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:52 +0200
commitc7747de83e6327cd5eb21854ba2b57e107e13e63 (patch)
tree26cb1d24d4dadee7bcfba1679b114e9191578ecd /gnu/packages
parent70f6df6839ec8157a1c85704c5e7482448877599 (diff)
downloadguix-c7747de83e6327cd5eb21854ba2b57e107e13e63.tar
guix-c7747de83e6327cd5eb21854ba2b57e107e13e63.tar.gz
gnu: texlive-latex-eepic -> texlive-eepic.
* gnu/packages/tex.scm (texlive-eepic): New variable. (texlive-latex-eepic): Deprecate variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm53
1 files changed, 21 insertions, 32 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 33f2a46170..9318456a88 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7254,43 +7254,32 @@ routine, which may be used to place the output at fixed positions. The
(define-deprecated-package texlive-latex-eso-pic texlive-eso-pic)
-(define-public texlive-latex-eepic
+(define-public texlive-eepic
(package
- (name "texlive-latex-eepic")
+ (name "texlive-eepic")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/eepic"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1c68gvh021pvybg07apsd2xhq2ljbg80kq94wh71drdga3c2zqjw"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/eepic")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/eepic/"
+ "tex/latex/eepic/")
+ (base32
+ "16v8j3f8bgww9adddpfzpwd5q9kvak7xnp5kkvkrvhw8vshdspaa")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-graphics))
(home-page "https://www.ctan.org/pkg/eepic")
- (synopsis "Extensions to epic and the LaTeX drawing tools")
- (description
- "Extensions to @code{epic} and the LaTeX picture drawing environment,
-include the drawing of lines at any slope, the drawing of circles in any
-radii, and the drawing of dotted and dashed lines much faster with much less
-TeX memory, and providing several new commands for drawing ellipses, arcs,
-splines, and filled circles and ellipses. The package uses @code{tpic}
-@code{\\special} commands.")
+ (synopsis "Extensions to @code{epic} and the LaTeX drawing tools")
+ (description
+ "This package provides extensions to @code{epic} and the LaTeX picture
+drawing environment. It includes the drawing of lines at any slope, the
+drawing of circles in any radii, and the drawing of dotted and dashed lines
+much faster with much less TeX memory, and providing several new commands for
+drawing ellipses, arcs, splines, and filled circles and ellipses.")
(license license:public-domain)))
+(define-deprecated-package texlive-latex-eepic texlive-eepic)
+
(define-public texlive-latex-enotez
(package
(inherit (simple-texlive-package