aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:10 +0200
commit8a24420f1d90a7eea853d20ffc75de7be69e8403 (patch)
treec8f75ad0d14862f05b7be95abba9a795b54fd7e9 /gnu/packages/web-browsers.scm
parent8c841634d0007ab9b2bba10e3baa3f7651a71b0c (diff)
downloadguix-8a24420f1d90a7eea853d20ffc75de7be69e8403.tar
guix-8a24420f1d90a7eea853d20ffc75de7be69e8403.tar.gz
gnu: lynx: Use G-expressions.
* gnu/packages/web-browsers.scm (lynx)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 7b3b08d474..2735b754fd 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -294,30 +294,30 @@ and the GTK+ toolkit.")
gzip
bzip2))
(arguments
- `(#:configure-flags
- (let ((openssl (assoc-ref %build-inputs "openssl")))
- `("--with-pkg-config"
- "--with-screen=ncurses"
- "--with-zlib"
- "--with-bzlib"
- ,(string-append "--with-ssl=" openssl)
- ;; "--with-socks5" ; XXX TODO
- "--enable-widec"
- "--enable-ascii-ctypes"
- "--enable-local-docs"
- "--enable-htmlized-cfg"
- "--enable-gzip-help"
- "--enable-nls"
- "--enable-ipv6"))
- #:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'set-makefile-shell
- (lambda _ (substitute* "po/makefile.inn"
- (("/bin/sh") (which "sh")))))
- (replace 'install
- (lambda* (#:key (make-flags '()) #:allow-other-keys)
- (apply invoke "make" "install-full" make-flags))))))
+ (list #:configure-flags
+ #~(let ((openssl #$(this-package-input "openssl")))
+ (list "--with-pkg-config"
+ "--with-screen=ncurses"
+ "--with-zlib"
+ "--with-bzlib"
+ (string-append "--with-ssl=" openssl)
+ ;; "--with-socks5" ; XXX TODO
+ "--enable-widec"
+ "--enable-ascii-ctypes"
+ "--enable-local-docs"
+ "--enable-htmlized-cfg"
+ "--enable-gzip-help"
+ "--enable-nls"
+ "--enable-ipv6"))
+ #:tests? #f ; no check target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'set-makefile-shell
+ (lambda _ (substitute* "po/makefile.inn"
+ (("/bin/sh") (which "sh")))))
+ (replace 'install
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (apply invoke "make" "install-full" make-flags))))))
(synopsis "Text Web Browser")
(description
"Lynx is a fully-featured World Wide Web (WWW) client for users running