aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:10 +0200
commit8c841634d0007ab9b2bba10e3baa3f7651a71b0c (patch)
tree571a27266bc7c46e3feeeb503ecf64b155dd3a64 /gnu/packages/web-browsers.scm
parentec96833aab57d4f753e76ee9606268e488d38b99 (diff)
downloadguix-8c841634d0007ab9b2bba10e3baa3f7651a71b0c.tar
guix-8c841634d0007ab9b2bba10e3baa3f7651a71b0c.tar.gz
gnu: lynx: Update to 2.9.0dev.12.
* gnu/packages/web-browsers.scm (lynx): Update to 2.9.0dev.12. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index eaf1852a78..7b3b08d474 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -274,7 +274,7 @@ and the GTK+ toolkit.")
(define-public lynx
(package
(name "lynx")
- (version "2.9.0dev.9")
+ (version "2.9.0dev.12")
(source (origin
(method url-fetch)
(uri (string-append
@@ -282,7 +282,7 @@ and the GTK+ toolkit.")
"/lynx" version ".tar.bz2"))
(sha256
(base32
- "06jhv8ibfw1xkf8d8zrnkc2aw4d462s77hlp6f6xa6k8awzxvmkg"))))
+ "1rg8dqafq8ray37s0w855mahq7ywfb4qa4h5q676sxq0klamnid6"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config perl))
(inputs (list ncurses
@@ -314,12 +314,10 @@ and the GTK+ toolkit.")
(modify-phases %standard-phases
(add-before 'configure 'set-makefile-shell
(lambda _ (substitute* "po/makefile.inn"
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(replace 'install
(lambda* (#:key (make-flags '()) #:allow-other-keys)
- (apply invoke "make" "install-full" make-flags)
- #t)))))
+ (apply invoke "make" "install-full" make-flags))))))
(synopsis "Text Web Browser")
(description
"Lynx is a fully-featured World Wide Web (WWW) client for users running