aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 16:19:31 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:27 +0200
commitb64307b38b26b513bb075b049de543369dd18034 (patch)
treeb6beebe2ac736fe6e4c18370bfb23c86aa052c2e /gnu/packages/tex.scm
parent92f9c9975fa3555e9493347e131db25ca552f989 (diff)
downloadguix-b64307b38b26b513bb075b049de543369dd18034.tar
guix-b64307b38b26b513bb075b049de543369dd18034.tar.gz
gnu: Add texlive-lacheck-bin.
* gnu/packages/tex.scm (texlive-lacheck-bin): New variable. (texlive-lacheck)[propagated-inputs]: Add TEXLIVE-LACHECK-BIN. Change-Id: Ibc2032c323f7631469d00291d9769327620b82de
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5381801b2a..682c466872 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -39699,12 +39699,59 @@ generated code can be included in any LaTeX document.")
"1hhx65yd800bl3y2sq20lix60wd2b2j3k7n9s788mlsn8b0p7yq3")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-lacheck-bin))
(home-page "https://ctan.org/pkg/lacheck")
(synopsis "LaTeX checker")
(description
"Lacheck is a tool for finding common mistakes in LaTeX documents.")
(license license:gpl3+)))
+(define-public texlive-lacheck-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-lacheck-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '("lacheck"))
+ (delete-other-directories "texk" '())))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-lacheck" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "utils/lacheck"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "utils/lacheck"
+ (invoke "make" "install"))))))))
+ (native-inputs '())
+ (inputs '())
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-lacheck))
+ (synopsis "Binary for @code{texlive-lacheck}")
+ (description
+ "This package provides the binary for @code{texlive-lacheck}.")
+ (license (package-license texlive-lacheck))))
+
(define-public texlive-latex-git-log
(package
(name "texlive-latex-git-log")