aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 16:16:48 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:27 +0200
commit92f9c9975fa3555e9493347e131db25ca552f989 (patch)
tree1c6377b87bba1c544658fbc14332ef86edd7c402 /gnu/packages/tex.scm
parent98bb563bf936deed0b9208323cf66aaae23a02ce (diff)
downloadguix-92f9c9975fa3555e9493347e131db25ca552f989.tar
guix-92f9c9975fa3555e9493347e131db25ca552f989.tar.gz
gnu: Add texlive-lcdftypetools-bin.
* gnu/packages/tex.scm (texlive-lcdftypetools-bin): New variable. (texlive-lcdftypetools)[propagated-inputs]: Add TEXLIVE-LCDFTYPETOOLS-BIN. Change-Id: I3091f6122365dc087d030d0e1458ce412fd94e30
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm48
1 files changed, 47 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7a3e0f22e1..5381801b2a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -38803,7 +38803,7 @@ TeX.")
"0yjbc6rsf8c62qa1lyi9kjyjy2p0xlps19llnvly3xyhla08j76f")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (propagated-inputs (list texlive-glyphlist))
+ (propagated-inputs (list texlive-glyphlist texlive-lcdftypetools-bin))
(home-page "https://ctan.org/pkg/lcdf-typetools")
(synopsis "Bundle of outline font manipulation tools")
(description
@@ -38838,6 +38838,52 @@ a Type 1 font.
@end itemize")
(license license:gpl3+)))
+(define-public texlive-lcdftypetools-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-lcdftypetools-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '())
+ (delete-other-directories "texk" '("lcdf-typetools"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-lcdf-typetools" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "texk/lcdf-typetools"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/lcdf-typetools"
+ (invoke "make" "install"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list texlive-libkpathsea))
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-lcdftypetools))
+ (synopsis "Binaries for @code{texlive-lcdftypetools}")
+ (description
+ "This package provides the binaries for @code{texlive-lcdftypetools}.")
+ (license (package-license texlive-lcdftypetools))))
+
(define-public texlive-latex
(package
(name "texlive-latex")