aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-02 21:45:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:17 +0200
commit9692e2bb7c49ba9526dd023dba3b5d24404f466b (patch)
tree53737d2abf7e7f05cb9e3677b37fc14d897c7428 /gnu/packages/python-xyz.scm
parent8d14b1cbb60aaae926daa82849b892f9666e8b4f (diff)
downloadguix-9692e2bb7c49ba9526dd023dba3b5d24404f466b.tar
guix-9692e2bb7c49ba9526dd023dba3b5d24404f466b.tar.gz
gnu: snakemake-5: Patch version string.
* gnu/packages/python-xyz.scm (snakemake-5)[arguments]: Add phase 'patch-version. Change-Id: I647625e9d26b2ee06274a0c5bb844ccb87035537
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b3c6d9821e..b9a7c0b222 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13227,6 +13227,14 @@ approach.")
(substitute* "snakemake/dag.py"
(("\"job\": rule,")
"\"job\": rule.name,"))))
+ (add-after 'unpack 'patch-version
+ (lambda _
+ (substitute* "setup.py"
+ (("version=versioneer.get_version\\(\\)")
+ (format #f "version=~s" #$version)))
+ (substitute* '("snakemake/_version.py"
+ "versioneer.py")
+ (("0\\+unknown") #$version))))
;; For cluster execution Snakemake will call Python. Since there is
;; no suitable PYTHONPATH set, cluster execution will fail. We fix
;; this by calling the snakemake wrapper instead.