aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-02 21:39:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:17 +0200
commit8d14b1cbb60aaae926daa82849b892f9666e8b4f (patch)
tree4e802d21d53d1b6a2a5b25aee4109acd993d6634 /gnu/packages/python-xyz.scm
parent36a1e76173b025376ee880280d84bdb20febf52d (diff)
downloadguix-8d14b1cbb60aaae926daa82849b892f9666e8b4f.tar
guix-8d14b1cbb60aaae926daa82849b892f9666e8b4f.tar.gz
gnu: snakemake-5: Make compatible with tabulate 0.9.0.
* gnu/packages/python-xyz.scm (snakemake-5)[arguments]: Add phase 'tabulate-compatibility. Change-Id: I0b0ddafe9c2da91dbe10a584eb6fa0a3d5d62e87
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 788148f32b..b3c6d9821e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13222,6 +13222,11 @@ approach.")
"--ignore=tests/test_google_lifesciences.py")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'tabulate-compatibility
+ (lambda _
+ (substitute* "snakemake/dag.py"
+ (("\"job\": rule,")
+ "\"job\": rule.name,"))))
;; For cluster execution Snakemake will call Python. Since there is
;; no suitable PYTHONPATH set, cluster execution will fail. We fix
;; this by calling the snakemake wrapper instead.