aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-11 16:15:15 -0500
committerjgart <jgart@dismail.de>2024-07-11 16:15:15 -0500
commit2088c135d4e58ea18a82e44cb2de1c4e10492900 (patch)
tree016da6eb13aaac7df2d3199e51011ebab506f519 /gnu/packages/python-xyz.scm
parentb3784c6326b398eb4efb0deea679674832004097 (diff)
downloadguix-2088c135d4e58ea18a82e44cb2de1c4e10492900.tar
guix-2088c135d4e58ea18a82e44cb2de1c4e10492900.tar.gz
gnu: python-typed-ast: Use new style.
* gnu/packages/python-xyz.scm (python-typed-ast) [arguments]: Use new style. Change-Id: I6817270eca0c19bc786aa77460759f32d47a2948
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 115ccef217..daaa521568 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26314,12 +26314,12 @@ source bytes using the UTF-8 encoding and then rewrites Python 3.6 style
(file-name (git-file-name name version))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs (list python-pytest))
(home-page "https://github.com/python/typed_ast")
(synopsis "Fork of Python @code{ast} modules with type comment support")