aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-11 16:12:03 -0500
committerjgart <jgart@dismail.de>2024-07-11 16:12:03 -0500
commitb3784c6326b398eb4efb0deea679674832004097 (patch)
treea25a4d6fdeaf20e6b025aab4e0597301fbd99479 /gnu/packages/python-xyz.scm
parent7e9a6836cd529e7d5f6fe7ee0167b09c989ee72e (diff)
downloadguix-b3784c6326b398eb4efb0deea679674832004097.tar
guix-b3784c6326b398eb4efb0deea679674832004097.tar.gz
gnu: python-typed-ast: Make the 'check' phase respect #:tests?.
* gnu/packages/python-xyz.scm (python-typed-ast) [arguments]: Make the 'check' phase respect #:tests?. Change-Id: I6817270eca0c19bc786aa77460759f32d47a2948
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2618c2078d..115ccef217 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26317,8 +26317,9 @@ source bytes using the UTF-8 encoding and then rewrites Python 3.6 style
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs (list python-pytest))
(home-page "https://github.com/python/typed_ast")
(synopsis "Fork of Python @code{ast} modules with type comment support")