aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-25 12:27:34 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-25 12:31:38 +0800
commit01ae23649516f9ef0d9e824cf541f380047714e6 (patch)
tree700862452f4e9caf2dd4f4bcc3099f5ed25e9c14 /gnu/packages/python-xyz.scm
parent53f58596c928397e4e31cf08196db0102dc8950f (diff)
downloadguix-01ae23649516f9ef0d9e824cf541f380047714e6.tar
guix-01ae23649516f9ef0d9e824cf541f380047714e6.tar.gz
Revert "gnu: python-mako: Improve package style."
This reverts commit 53f58596c928397e4e31cf08196db0102dc8950f. This introduces too many rebuilds. Change-Id: I6f7e1a01df90db4f51d3d64140740e7f29339f3d
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9291d8c4a3..fcf01f3d04 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19234,14 +19234,13 @@ of @acronym{REGEXPs, regular expressions}.")
"0gqnv9py1dqp01jmf5zxp0vj2dbhq1l9zy55fai319iv6sdqc91p"))))
(build-system python-build-system)
(arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%")))))))
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest" "-vv")
+ (format #t "test suite not run~%"))
+ #t)))))
(propagated-inputs
(list python-markupsafe))
(native-inputs