aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-24 22:37:12 -0500
committerjgart <jgart@dismail.de>2024-07-24 22:37:12 -0500
commit53f58596c928397e4e31cf08196db0102dc8950f (patch)
treea3bb0585157c6d1d498ee8d0c8c900d719b113cf /gnu/packages/python-xyz.scm
parent628189f919a1280ed2e187e7ca5d63fe08cb78dd (diff)
downloadguix-53f58596c928397e4e31cf08196db0102dc8950f.tar
guix-53f58596c928397e4e31cf08196db0102dc8950f.tar.gz
gnu: python-mako: Improve package style.
* gnu/packages/python-xyz.scm (python-mako) [arguments]: Use G-expressions. Change-Id: Ib33ddae71a7913dccbc3117644c8efd1058e0747
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fcf01f3d04..9291d8c4a3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19234,13 +19234,14 @@ of @acronym{REGEXPs, regular expressions}.")
"0gqnv9py1dqp01jmf5zxp0vj2dbhq1l9zy55fai319iv6sdqc91p"))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%"))
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest" "-vv")
+ (format #t "test suite not run~%")))))))
(propagated-inputs
(list python-markupsafe))
(native-inputs