aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-07-17 22:37:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-17 22:38:07 +0200
commit0efdf33d0efda16a670b1d2f0f93e07e54df38e3 (patch)
treec6a205b644982e8e72f7335a5c2bcc2077aff083 /gnu/packages/python-web.scm
parent126dde2fb570526c474b8f1aa0d055c5195e784b (diff)
downloadguix-0efdf33d0efda16a670b1d2f0f93e07e54df38e3.tar
guix-0efdf33d0efda16a670b1d2f0f93e07e54df38e3.tar.gz
gnu: python-cloud-init: Update to 24.2.
* gnu/packages/python-web.scm (python-cloud-init): Update to 24.2. [arguments]: Disable apt tests. Change-Id: I1a024ded4108121cc2960cadab4da94416290913
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 01b85d1850..30da9c8c3c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7424,7 +7424,7 @@ Encoding for HTTP.")
(define-public python-cloud-init
(package
(name "python-cloud-init")
- (version "23.4.3")
+ (version "24.2")
(source
(origin
(method git-fetch)
@@ -7433,7 +7433,7 @@ Encoding for HTTP.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0przjj2j1ws6b7sbgqxnffsarbbwl00lhq3bn7yiksp8kg8np1m1"))))
+ (base32 "18872z2y9wkh558y1bx5r0rksb4i584jbc8z4g8marwawhwxq506"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -7447,6 +7447,7 @@ Encoding for HTTP.")
(string-append
;; This test messes with PATH, so it cannot find mkdir
"not test_path_env_gets_set_from_main"
+ " and not test_apt_configure_sources_list_"
;; These all fail because /bin/sh doesn't exist. We cannot patch
;; this because the generated scripts must use /bin/sh as they are
;; supposed to be run on minimal systems.