aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-07-04 16:44:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-17 22:38:07 +0200
commit126dde2fb570526c474b8f1aa0d055c5195e784b (patch)
tree9698395387aa316d5f59912ad71a2a6d0c623761 /gnu/packages/python-web.scm
parent6cfc88e3be73904fc87443cdd5c7d7961923e848 (diff)
downloadguix-126dde2fb570526c474b8f1aa0d055c5195e784b.tar
guix-126dde2fb570526c474b8f1aa0d055c5195e784b.tar.gz
gnu: python-cloud-init: Move files.
* gnu/packages/python-web.scm (python-cloud-init)[arguments]: Add phase 'move-files to move data files out of site-packages directory. Change-Id: I1322b990226174283d724539a98f7470221e9058
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ae63d58131..01b85d1850 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7455,11 +7455,19 @@ Encoding for HTTP.")
" and not test_subp_combined_stderr_stdout"
" and not test_handle_part"))
#:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'patch-references
- (lambda _
- (substitute* "tests/unittests/cmd/test_clean.py"
- (("#!/bin/sh") (string-append "#!" (which "sh")))))))))
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-references
+ (lambda _
+ (substitute* "tests/unittests/cmd/test_clean.py"
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))))
+ (add-after 'install 'move-files
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (for-each (lambda (dir)
+ (let ((source (string-append (site-packages inputs outputs) "/" dir))
+ (target (string-append #$output "/" (basename dir))))
+ (copy-recursively source target)
+ (delete-file-recursively source)))
+ (list "etc" "lib" "usr/lib" "usr/share")))))))
(propagated-inputs
(list python-configobj
python-jinja2