aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2022-10-17 22:38:16 -0300
committerChristopher Baines <mail@cbaines.net>2022-10-18 10:58:48 +0100
commitd45c5a47ba00d21bc116917ccedbaca3005456f9 (patch)
tree1ee6574e1e6be50906655e0fa07435a1334b79dd /gnu/packages/perl.scm
parent4acc8a901918ac9378b66b762fbc82e5e76d9438 (diff)
downloadguix-d45c5a47ba00d21bc116917ccedbaca3005456f9.tar
guix-d45c5a47ba00d21bc116917ccedbaca3005456f9.tar.gz
gnu: Add perl-ppix-quotelike.
* gnu/packages/perl.scm (perl-ppix-quotelike): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e3e78785a2..e69803254c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8810,6 +8810,29 @@ Perl. This class forms the root of the parse tree, playing a role similar to
@code{PPI::Document}.")
(license license:perl-license)))
+(define-public perl-ppix-quotelike
+ (package
+ (name "perl-ppix-quotelike")
+ (version "0.023")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/W/WY/WYANT/PPIx-QuoteLike-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "08ad4d20afvi1c4xzwbfk94lmf6gwlmqkdrpjxzf0lrcklaa6xim"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (propagated-inputs (list perl-ppi perl-ppix-regexp perl-readonly))
+ (home-page "https://metacpan.org/release/PPIx-QuoteLike")
+ (synopsis "Parse Perl string literals and string-literal-like things")
+ (description
+ "@code{PPIX::QuoteLike} parses Perl string literals and things that
+are reasonably like string literals. Its real reason for being is to find
+interpolated variables for @code{Perl::Critic} policies and similar code.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")