aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2022-10-17 22:38:15 -0300
committerChristopher Baines <mail@cbaines.net>2022-10-18 10:58:48 +0100
commit4acc8a901918ac9378b66b762fbc82e5e76d9438 (patch)
treeac759ac0a6fba598f9f8ad40c1fe4ea7fc25828b /gnu/packages/perl.scm
parent2a531bfb3445d723bfb915576e266f2094936aef (diff)
downloadguix-4acc8a901918ac9378b66b762fbc82e5e76d9438.tar
guix-4acc8a901918ac9378b66b762fbc82e5e76d9438.tar.gz
gnu: Add perl-ppix-regexp.
* gnu/packages/perl.scm (perl-ppix-regexp): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 31b2abde48..e3e78785a2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8786,6 +8786,30 @@ applications.")
code.")
(license license:perl-license)))
+(define-public perl-ppix-regexp
+ (package
+ (name "perl-ppix-regexp")
+ (version "0.085")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/W/WY/WYANT/PPIx-Regexp-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "07fg63ql3f7hv1ys10l8j0p562ndraq9lk66iw9y0f444j4vpw1f"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (propagated-inputs (list perl-ppi))
+ (home-page "https://metacpan.org/release/PPIx-Regexp")
+ (synopsis "Parse Perl string literals and string-literal-like things")
+ (description
+ "The purpose of the @code{PPIx-Regexp} package is to parse
+regular expressions in a manner similar to the way the @code{PPI} package parses
+Perl. This class forms the root of the parse tree, playing a role similar to
+@code{PPI::Document}.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")