aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-08-02 21:37:17 -0700
committerChristopher Baines <mail@cbaines.net>2024-08-11 10:47:52 +0100
commit8b943673a15a337c48c71cecad18d9eb68143d95 (patch)
tree4c048626529fbc64194cb95e2f310f7bb76ec8fb /gnu/packages/patches
parentd0dc4c5a6932a100c912947a6c9f090d22672ef1 (diff)
downloadguix-8b943673a15a337c48c71cecad18d9eb68143d95.tar
guix-8b943673a15a337c48c71cecad18d9eb68143d95.tar.gz
gnu: xpra: Update to 6.1.0.
* gnu/packages/xorg.scm (xpra): Update to 6.1.0. [source](origin): Update patch file name. * gnu/packages/patches/xpra-6.0-install_libs.patch: Delete. * gnu/packages/patches/xpra-6.1-install_libs.patch: New file. * gnu/local.mk: Unregister deleted file and register new file. Change-Id: I38dab99fbb369ab7e8daf2795dc37aa1a36a63de Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/xpra-6.1-install_libs.patch (renamed from gnu/packages/patches/xpra-6.0-install_libs.patch)10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/patches/xpra-6.0-install_libs.patch b/gnu/packages/patches/xpra-6.1-install_libs.patch
index c608b519f4..0ec2aee288 100644
--- a/gnu/packages/patches/xpra-6.0-install_libs.patch
+++ b/gnu/packages/patches/xpra-6.1-install_libs.patch
@@ -4,19 +4,19 @@ This workaround for Gentoo interferes with our use of --no-compile during
the 'install stage.
diff --git a/setup.py b/setup.py
-index 4f066fa8bf..14a9ed65ed 100755
+index be7a3758e8..28dc1be191 100755
--- a/setup.py
+++ b/setup.py
-@@ -760,8 +760,6 @@ if modules_ENABLED:
+@@ -953,8 +953,6 @@ if modules_ENABLED:
# Utility methods for building with Cython
- def do_add_cython_ext(*args, **kwargs):
+ def do_add_cython_ext(*args, **kwargs) -> None:
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
- return
if not cython_ENABLED:
raise ValueError(f"cannot build {args}: cython compilation is disabled")
if cython_tracing_ENABLED:
-@@ -1971,9 +1969,6 @@ else:
+@@ -2175,9 +2173,6 @@ else:
if root_prefix.endswith("/usr"):
# ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
root_prefix = root_prefix[:-4]
@@ -26,7 +26,7 @@ index 4f066fa8bf..14a9ed65ed 100755
print(f" root_prefix={root_prefix!r}")
build_xpra_conf(root_prefix)
-@@ -2116,13 +2111,6 @@ else:
+@@ -2320,13 +2315,6 @@ else:
if uinput_ENABLED:
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])