aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/xpra-6.1-install_libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/xpra-6.1-install_libs.patch')
-rw-r--r--gnu/packages/patches/xpra-6.1-install_libs.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/patches/xpra-6.1-install_libs.patch b/gnu/packages/patches/xpra-6.1-install_libs.patch
new file mode 100644
index 0000000000..0ec2aee288
--- /dev/null
+++ b/gnu/packages/patches/xpra-6.1-install_libs.patch
@@ -0,0 +1,42 @@
+Distribution specific patch, not going upstream
+
+This workaround for Gentoo interferes with our use of --no-compile during
+the 'install stage.
+
+diff --git a/setup.py b/setup.py
+index be7a3758e8..28dc1be191 100755
+--- a/setup.py
++++ b/setup.py
+@@ -953,8 +953,6 @@ if modules_ENABLED:
+ # Utility methods for building with Cython
+
+ def do_add_cython_ext(*args, **kwargs) -> None:
+- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
+- return
+ if not cython_ENABLED:
+ raise ValueError(f"cannot build {args}: cython compilation is disabled")
+ if cython_tracing_ENABLED:
+@@ -2175,9 +2173,6 @@ else:
+ if root_prefix.endswith("/usr"):
+ # ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
+ root_prefix = root_prefix[:-4]
+- for x in sys.argv:
+- if x.startswith("--root="):
+- root_prefix = x[len("--root="):]
+ print(f" root_prefix={root_prefix!r}")
+ build_xpra_conf(root_prefix)
+
+@@ -2320,13 +2315,6 @@ else:
+ if uinput_ENABLED:
+ add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
+
+- # gentoo does weird things, calls --no-compile with build *and* install
+- # then expects to find the cython modules!? ie:
+- #> python2.7 setup.py build -b build-2.7 install --no-compile \
+- # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
+- # otherwise we use the flags to skip pkgconfig
+- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv): # noqa: E501
+- pkgconfig = no_pkgconfig
+
+ if OSX and "py2app" in sys.argv:
+ import py2app #@UnresolvedImport