aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorArnaud DABY-SEESARAM <ds-ac@nanein.fr>2024-01-10 08:43:23 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-08 23:20:46 +0100
commitda2521a63f0c7f0becd144499f3d09f5d4b8a0ed (patch)
treec3b041b643ac97b4d8155b079f49ba2f206536dd /gnu/packages/ocaml.scm
parent10d8b7523cb9c65d2bf68853653b89fc3bc49f1a (diff)
downloadguix-da2521a63f0c7f0becd144499f3d09f5d4b8a0ed.tar
guix-da2521a63f0c7f0becd144499f3d09f5d4b8a0ed.tar.gz
gnu: Add ocaml-junit-alcotest.
* gnu/packages/ocaml.scm (ocaml-junit-alcotest): New variable. Change-Id: I377bbba90e8625a47680643db2ef84fabbe60908 Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 97bf7485b6..60cb47b369 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1648,6 +1648,22 @@ to be accepted by Jenkins.")
;; with OCaml linking exception
(license license:gpl3+)))
+(define-public ocaml-junit-alcotest
+ (package
+ (inherit ocaml-junit)
+ (name "ocaml-junit-alcotest")
+ (propagated-inputs (list ocaml-odoc ocaml-alcotest ocaml-junit))
+ (build-system dune-build-system)
+ (arguments
+ `(#:package "junit_alcotest"
+ #:tests? #f)); tests fail
+ (properties `((upstream-name . "junit_alcotest")))
+ (synopsis "JUnit XML reports generation for alcotest tests")
+ (description "This package generates JUnit XML reports from ocaml-alcotest
+test suites.")
+ ;; with OCaml linking exception
+ (license license:gpl3+)))
+
(define-public camlzip
(package
(name "camlzip")