aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorArnaud DABY-SEESARAM <ds-ac@nanein.fr>2024-01-10 08:43:22 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-08 23:20:25 +0100
commit10d8b7523cb9c65d2bf68853653b89fc3bc49f1a (patch)
treedeeb6587d5bbec802a7030f74ca8fd3ae485227b /gnu/packages/ocaml.scm
parentccd5965ed04ff16309b4561815b5604c33e71291 (diff)
downloadguix-10d8b7523cb9c65d2bf68853653b89fc3bc49f1a.tar
guix-10d8b7523cb9c65d2bf68853653b89fc3bc49f1a.tar.gz
gnu: Add ocaml-junit.
* gnu/packages/ocaml.scm (ocaml-junit): New variable. Change-Id: I69fd4302b0a178765a79a72801eed694b3bd3ebd Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 700e1edfb0..97bf7485b6 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1618,6 +1618,36 @@ to JUnit and other XUnit testing frameworks.")
other XUnit testing frameworks.")
(license license:expat)))
+(define-public ocaml-junit
+ (package
+ (name "ocaml-junit")
+ (version "2.0.2")
+ (home-page "https://github.com/Khady/ocaml-junit")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cam7zzarrh9p1l5m3ba3h5rkh9mhark8j37rjgw35a66qd0gds1"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:package "junit"
+ #:phases (modify-phases %standard-phases
+ (add-before 'build 'dune-subst
+ (lambda _
+ (invoke "dune" "subst") #t)))))
+ (properties `((upstream-name . "junit")))
+ (propagated-inputs (list ocaml-ounit ocaml-ptime ocaml-tyxml ocaml-odoc))
+ (synopsis "JUnit XML reports generation library")
+ (description "Ocaml-junit is a package for the creation of JUnit XML
+reports. It provides a typed API to produce valid reports. They are supposed
+to be accepted by Jenkins.")
+ ;; with OCaml linking exception
+ (license license:gpl3+)))
+
(define-public camlzip
(package
(name "camlzip")