aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorArnaud DABY-SEESARAM <ds-ac@nanein.fr>2024-01-10 08:43:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-08 23:20:01 +0100
commitccd5965ed04ff16309b4561815b5604c33e71291 (patch)
tree32b5a8142a6c70af6552773ceab998fbbd194483 /gnu/packages/ocaml.scm
parent30ad3fb059e0fa6665a83cfcee4114e079746e0b (diff)
downloadguix-ccd5965ed04ff16309b4561815b5604c33e71291.tar
guix-ccd5965ed04ff16309b4561815b5604c33e71291.tar.gz
gnu: Add ocaml-ppx-deriving-yojson.
* gnu/packages/ocaml.scm (ocaml-ppx-deriving-yojson): New variable. Change-Id: I3f5dfdf39c7e7d9655fc26ee6cc88a2c30485d57 Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ba50d4f35c..700e1edfb0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
;;; Copyright © 2023 Csepp <raingloom@riseup.net>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023 Arnaud DABY-SEESARAM <ds-ac@nanein.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6211,6 +6212,34 @@ ppx_deriving and ppx_type_conv to inter-operate gracefully when linked
as part of the same ocaml-migrate-parsetree driver.")
(license license:bsd-3)))
+(define-public ocaml-ppx-deriving-yojson
+ (package
+ (name "ocaml-ppx-deriving-yojson")
+ (version "3.7.0")
+ (home-page "https://github.com/ocaml-ppx/ppx_deriving_yojson")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nazam6zlzm9ngyyr1q7s1vmw162fnrvsn8r6bsn5lnpaygv28ly"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ (list ocaml-yojson
+ ocaml-result
+ ocaml-ppx-deriving
+ ocaml-ppxlib))
+ (native-inputs (list ocaml-ounit))
+ (properties `((upstream-name . "ppx_deriving_yojson")))
+ (synopsis "JSON codec generator for OCaml")
+ (description
+ "Ppx_deriving_yojson is a ppx_deriving plugin that provides a JSON codec
+generator.")
+ (license license:expat)))
+
(define-public ocaml-cinaps
;; The commit removes the unused dependency of ocaml-ppx-jane. We need to
;; use this as we would otherwise have a dependency loop between