aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:47 +0000
commit25e9450d2a03b95bd7c86e3134d95c3f0aa53844 (patch)
tree73bde6abd458e109b6d3642b27c0a17b0607d464 /gnu/packages/node-xyz.scm
parentf96bc239b78c06f1a3cd8faf80135077d0d9cb47 (diff)
downloadguix-25e9450d2a03b95bd7c86e3134d95c3f0aa53844.tar
guix-25e9450d2a03b95bd7c86e3134d95c3f0aa53844.tar.gz
gnu: node-debug: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-debug): Move package in alphabetical order. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm84
1 files changed, 42 insertions, 42 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 45dbe8693e..d5b2476265 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -305,6 +305,48 @@ and fancy character sets, signed or unsigned data and has tests, for Node.")
64.0.3242 and above and all other browsers supporting the file format and API.")
(license license:bsd-3)))
+(define-public node-debug
+ (package
+ (name "node-debug")
+ (version "4.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/debug-js/debug")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ji0dmdl2xkgxqxvd6xjy7k3mmknmhvqjgc40vyly9ka1mpf20vb"))))
+ (inputs
+ (list node-ms))
+ (build-system node-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda args
+ (delete-dependencies `("brfs"
+ "browserify"
+ "coveralls"
+ "istanbul"
+ "karma"
+ "karma-browserify"
+ "karma-chrome-launcher"
+ "karma-mocha"
+ "mocha"
+ "mocha-lcov-reporter"
+ "xo"
+ "supports-color")))))
+ #:tests? #f))
+ (home-page "https://github.com/debug-js/debug")
+ (synopsis "Debugging utility for Node.js")
+ (description "The @code{debug} module exposes a function, which if called
+with a module name as argument provides a function that writes debug output to
+@code{console.error} under that module name. This output can be controlled in
+a more fine-grained manner by binding the @env{DEBUG} variable.")
+ (license license:expat)))
+
(define-public node-env-variable
(package
(name "node-env-variable")
@@ -1345,48 +1387,6 @@ function with browser support.")
particular cross-platform spellings of the PATH environment variable key.")
(license license:expat)))
-(define-public node-debug
- (package
- (name "node-debug")
- (version "4.3.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/debug-js/debug")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0ji0dmdl2xkgxqxvd6xjy7k3mmknmhvqjgc40vyly9ka1mpf20vb"))))
- (inputs
- (list node-ms))
- (build-system node-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies `("brfs"
- "browserify"
- "coveralls"
- "istanbul"
- "karma"
- "karma-browserify"
- "karma-chrome-launcher"
- "karma-mocha"
- "mocha"
- "mocha-lcov-reporter"
- "xo"
- "supports-color")))))
- #:tests? #f))
- (home-page "https://github.com/debug-js/debug")
- (synopsis "Debugging utility for Node.js")
- (description "The @code{debug} module exposes a function, which if called
-with a module name as argument provides a function that writes debug output to
-@code{console.error} under that module name. This output can be controlled in
-a more fine-grained manner by binding the @env{DEBUG} variable.")
- (license license:expat)))
-
(define-public node-serialport-binding-abstract
(package
(name "node-serialport-binding-abstract")