aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:47 +0000
commitf96bc239b78c06f1a3cd8faf80135077d0d9cb47 (patch)
treeeb1fd12051506a3761fb478d0b46abcbf1572281 /gnu/packages/node-xyz.scm
parent8cc24d344a87d552367143267430b5ca4a29c644 (diff)
downloadguix-f96bc239b78c06f1a3cd8faf80135077d0d9cb47.tar
guix-f96bc239b78c06f1a3cd8faf80135077d0d9cb47.tar.gz
gnu: node-ms: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-ms): Move package in alphabetical order. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm66
1 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index cc61c0b5fe..45dbe8693e 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -623,6 +623,39 @@ random number generator.")
Javascript.")
(license license:expat)))
+(define-public node-ms
+ (package
+ (name "node-ms")
+ (version "2.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vercel/ms")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l74kmmwffmzdz38lli0v5mdb9p9jmsjxpb48ncknqw2n74cgf08"))))
+ (build-system node-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda args
+ (delete-dependencies `("eslint"
+ "expect.js"
+ "husky"
+ "lint-staged"
+ "mocha"
+ "prettier")))))
+ #:tests? #f))
+ (home-page "https://github.com/vercel/ms")
+ (synopsis "Convert time to milliseconds")
+ (description "Use this package to easily convert various time formats to
+milliseconds. A number supplied as integer or string is returned as-is, while
+a string consisting of a number and a time unit is converted to milliseconds.")
+ (license license:expat)))
+
(define-public node-nan
(package
(name "node-nan")
@@ -1312,39 +1345,6 @@ function with browser support.")
particular cross-platform spellings of the PATH environment variable key.")
(license license:expat)))
-(define-public node-ms
- (package
- (name "node-ms")
- (version "2.1.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vercel/ms")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1l74kmmwffmzdz38lli0v5mdb9p9jmsjxpb48ncknqw2n74cgf08"))))
- (build-system node-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies `("eslint"
- "expect.js"
- "husky"
- "lint-staged"
- "mocha"
- "prettier")))))
- #:tests? #f))
- (home-page "https://github.com/vercel/ms")
- (synopsis "Convert time to milliseconds")
- (description "Use this package to easily convert various time formats to
-milliseconds. A number supplied as integer or string is returned as-is, while
-a string consisting of a number and a time unit is converted to milliseconds.")
- (license license:expat)))
-
(define-public node-debug
(package
(name "node-debug")