aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 07:36:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:40 +0100
commit9708590d209aa2fea3a0f96a79bc3abb4c6d2395 (patch)
tree8889c1908cd66a8b7275a003350bf287129c950c /gnu/packages/golang.scm
parent9cfcc16c2f42cf62656e1da23bc43cee03787b43 (diff)
downloadguix-9708590d209aa2fea3a0f96a79bc3abb4c6d2395.tar
guix-9708590d209aa2fea3a0f96a79bc3abb4c6d2395.tar.gz
gnu: Remove go-golang.org-x-sync-errgroup.
* gnu/packages/golang-build.scm (go-golang.org-x-sync-errgroup): Delete variable. * gnu/packages/check.scm (actionlint): Adjust inputs. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/golang.scm (gotestsum): Likewise. [native-inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/golang.scm (go-github-com-prometheus-procfs): Likewise. [propagated-inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/terminals.scm (go-github-com-junegunn-fzf): Likewise. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/version-control.scm (ghq): Likewise. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. Change-Id: If64c30da47ed9cd043798f427f2927b76394f3c4
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6f267cbd0c..7f8e7734fc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6207,7 +6207,7 @@ test when a comparison fails.")
'(#:import-path "gotest.tools/gotestsum"))
(native-inputs
(list go-github-com-fatih-color
- go-golang.org-x-sync-errgroup
+ go-golang-org-x-sync
go-github-com-pkg-errors
go-github-com-sirupsen-logrus
go-github-com-spf13-pflag
@@ -7626,7 +7626,7 @@ Prometheus metrics.")
;; The tests require Go modules, which are not yet supported in Guix's
;; Go build system.
#:tests? #f))
- (propagated-inputs (list go-golang.org-x-sync-errgroup))
+ (propagated-inputs (list go-golang-org-x-sync))
(synopsis "Go library for reading @file{/proc}")
(description "The @code{procfs} Go package provides functions to retrieve
system, kernel, and process metrics from the @file{/proc} pseudo file system.")