aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 07:36:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:40 +0100
commit9708590d209aa2fea3a0f96a79bc3abb4c6d2395 (patch)
tree8889c1908cd66a8b7275a003350bf287129c950c
parent9cfcc16c2f42cf62656e1da23bc43cee03787b43 (diff)
downloadguix-9708590d209aa2fea3a0f96a79bc3abb4c6d2395.tar
guix-9708590d209aa2fea3a0f96a79bc3abb4c6d2395.tar.gz
gnu: Remove go-golang.org-x-sync-errgroup.
* gnu/packages/golang-build.scm (go-golang.org-x-sync-errgroup): Delete variable. * gnu/packages/check.scm (actionlint): Adjust inputs. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/golang.scm (gotestsum): Likewise. [native-inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/golang.scm (go-github-com-prometheus-procfs): Likewise. [propagated-inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/terminals.scm (go-github-com-junegunn-fzf): Likewise. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/version-control.scm (ghq): Likewise. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. Change-Id: If64c30da47ed9cd043798f427f2927b76394f3c4
-rw-r--r--gnu/packages/check.scm2
-rw-r--r--gnu/packages/golang-build.scm29
-rw-r--r--gnu/packages/golang.scm4
-rw-r--r--gnu/packages/terminals.scm2
-rw-r--r--gnu/packages/version-control.scm2
5 files changed, 6 insertions, 33 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index bbd9cf3181..8a8a8f16a0 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1063,7 +1063,7 @@ but it works for any C/C++ project.")
go-github-com-mattn-go-colorable
go-github-com-mattn-go-runewidth
go-github-com-robfig-cron
- go-golang.org-x-sync-errgroup
+ go-golang-org-x-sync
go-golang.org-x-sync-semaphore
go-gopkg-in-yaml-v3))
(native-inputs (list go-github-com-google-go-cmp-cmp))
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index bccacf59f4..d69746a9be 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -293,36 +293,9 @@ addition to the ones provided by the language and “sync” and “sync/atomic
packages.")
(license license:bsd-3))))
-(define-public go-golang.org-x-sync-errgroup
- (let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
- (revision "0"))
- (package
- (name "go-golang.org-x-sync-errgroup")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/sync")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1nqkyz2y1qvqcma52ijh02s8aiqmkfb95j08f6zcjhbga3ds6hds"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/sync/errgroup"
- #:unpack-path "golang.org/x/sync"))
- (home-page "https://godoc.org/golang.org/x/sync/errgroup")
- (synopsis "Synchronization, error propagation, and Context cancellation
-for groups of goroutines working on subtasks of a common task")
- (description "This package provides synchronization, error
-propagation, and Context cancellation for groups of goroutines working on
-subtasks of a common task.")
- (license license:bsd-3))))
-
(define-public go-golang.org-x-sync-semaphore
(package
- (inherit go-golang.org-x-sync-errgroup)
+ (inherit go-golang-org-x-sync)
(name "go-golang.org-x-sync-semaphore")
(arguments
'(#:import-path "golang.org/x/sync/semaphore"
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6f267cbd0c..7f8e7734fc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6207,7 +6207,7 @@ test when a comparison fails.")
'(#:import-path "gotest.tools/gotestsum"))
(native-inputs
(list go-github-com-fatih-color
- go-golang.org-x-sync-errgroup
+ go-golang-org-x-sync
go-github-com-pkg-errors
go-github-com-sirupsen-logrus
go-github-com-spf13-pflag
@@ -7626,7 +7626,7 @@ Prometheus metrics.")
;; The tests require Go modules, which are not yet supported in Guix's
;; Go build system.
#:tests? #f))
- (propagated-inputs (list go-golang.org-x-sync-errgroup))
+ (propagated-inputs (list go-golang-org-x-sync))
(synopsis "Go library for reading @file{/proc}")
(description "The @code{procfs} Go package provides functions to retrieve
system, kernel, and process metrics from the @file{/proc} pseudo file system.")
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 3ab79837e0..c227ff53dc 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1039,7 +1039,7 @@ programmer to write text-based user interfaces.")
go-github-com-gdamore-tcell
go-github-com-rivo-uniseg
go-github-com-saracen-walker
- go-golang.org-x-sync-errgroup
+ go-golang-org-x-sync
go-golang-org-x-term
go-golang-org-x-crypto))
(home-page "https://github.com/junegunn/fzf")
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index afa7700413..22e281bc3d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3850,7 +3850,7 @@ If several repos are related, it helps to see their status together.")
go-github-com-saracen-walker
go-github-com-urfave-cli-v2
go-golang-org-x-net
- go-golang.org-x-sync-errgroup))
+ go-golang-org-x-sync))
(synopsis "Manage remote repository clones")
(description
"@code{ghq} provides a way to organize remote repository clones, like