aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:07:57 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:37:51 +0000
commit080f93132064eb16df0ea1d7d744975193c2a9de (patch)
tree436d55de01731eb5556c0fb54bd9873fbd88bbcd /gnu/packages/golang.scm
parent5f5d8167b19e21146b56299c44117fd1a6509eba (diff)
downloadguix-080f93132064eb16df0ea1d7d744975193c2a9de.tar
guix-080f93132064eb16df0ea1d7d744975193c2a9de.tar.gz
gnu: go-github-com-spf13-viper: Remove input labels.
* gnu/package/golang.scm (go-github-com-spf13-viper) [propagated-inputs]: Remove input labels. Change-Id: I0c8c616b9b44a2fd21f83dbfb609fe1bd861d657
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 58126f7eeb..74fc08f83d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3888,21 +3888,21 @@ GNU extensions} to the POSIX recommendations for command-line options.")
"099n2g7fg6r8hqyszqw2axr775qyhyvwhsykvgw0f0s16ql48h5c"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/spf13/viper"))
+ (list
+ #:import-path "github.com/spf13/viper"))
(propagated-inputs
- `(("github.com/spf13/afero" ,go-github-com-spf13-afero)
- ("github.com/spf13/cast" ,go-github-com-spf13-cast)
- ("github.com/spf13/pflag" ,go-github-com-spf13-pflag)
- ("github.com/spf13/jwalterweatherman" ,go-github-com-spf13-jwalterweatherman)
- ("github.com/fsnotify/fsnotify" ,go-github-com-fsnotify-fsnotify)
- ("github.com/hashicorp/hcl" ,go-github-com-hashicorp-hcl)
- ("github.com/magiconair/properties" ,go-github-com-magiconair-properties)
- ("github.com/mitchellh/mapstructure" ,go-github-com-mitchellh-mapstructure)
- ("github.com/pelletier/go-toml" ,go-github-com-pelletier-go-toml)
- ("github.com/subosito/gotenv" ,go-github-com-subosito-gotenv)
-
- ("gopkg.in/ini.v1" ,go-gopkg-in-ini-v1)
- ("gopkg.in/yaml.v2" ,go-gopkg-in-yaml-v2)))
+ (list go-github-com-fsnotify-fsnotify
+ go-github-com-hashicorp-hcl
+ go-github-com-magiconair-properties
+ go-github-com-mitchellh-mapstructure
+ go-github-com-pelletier-go-toml
+ go-github-com-spf13-afero
+ go-github-com-spf13-cast
+ go-github-com-spf13-jwalterweatherman
+ go-github-com-spf13-pflag
+ go-github-com-subosito-gotenv
+ go-gopkg-in-ini-v1
+ go-gopkg-in-yaml-v2))
(native-inputs
(list go-github-com-stretchr-testify))
(home-page "https://github.com/spf13/viper")