aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:03:39 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:31 +0000
commit5f5d8167b19e21146b56299c44117fd1a6509eba (patch)
tree68788fbbe0d34b465d7f1e8c1eabcf74f3df9317 /gnu/packages/golang.scm
parente6ce91d1bf610baba201d9d81557d79baa15ccd8 (diff)
downloadguix-5f5d8167b19e21146b56299c44117fd1a6509eba.tar
guix-5f5d8167b19e21146b56299c44117fd1a6509eba.tar.gz
gnu: go-github-com-hashicorp-go-uuid: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-hashicorp-go-uuid): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ib97abb60b716c971bb54144d7d1ea015211e1ed4
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4382b12f7c..58126f7eeb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3500,31 +3500,6 @@ editor.")
spec in Go.")
(license license:bsd-3))))
-(define-public go-github-com-hashicorp-go-uuid
- (package
- (name "go-github-com-hashicorp-go-uuid")
- (version "1.0.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hashicorp/go-uuid")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0wd4maaq20alxwcvfhr52rzfnwwpmc2a698ihyr0vfns2sl7gkzk"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/hashicorp/go-uuid"))
- (home-page "https://github.com/hashicorp/go-uuid")
- (synopsis "Generate UUID-format strings")
- (description
- "This package generates UUID-format strings using high quality bytes.
-It is not intended to be RFC compliant, merely to use a well-understood string
-representation of a 128-bit value. It can also parse UUID-format strings into
-their component bytes.")
- (license license:mpl2.0)))
-
(define-public go-github-com-hashicorp-go-version
(let ((commit
"03c5bf6be031b6dd45afec16b1cf94fc8938bc77")