aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-15 09:17:12 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 23:07:39 +0100
commit79bc5c20b27d5e48f4a2dd47847875e05c95e4f3 (patch)
tree01eb8fdbfcf4184b4e80ee9ce383b838196c14b7 /gnu/packages/golang-web.scm
parent08f391af7839a935d746ae7fdd4bb66666c90f28 (diff)
downloadguix-79bc5c20b27d5e48f4a2dd47847875e05c95e4f3.tar
guix-79bc5c20b27d5e48f4a2dd47847875e05c95e4f3.tar.gz
gnu: Add go-github-com-pion-transport-v2.
* gnu/packages/golang-web.scm (go-github-com-pion-transport-v2): New variable. Change-Id: I5d79c066fd7c26121d3903efd02dff07f54cd670 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 8c8f176964..372a88f126 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1650,6 +1650,24 @@ packetizer and depacketizer.")
throughout the @url{https://github.com/pion, Pion} modules.")
(license license:expat)))
+(define-public go-github-com-pion-transport-v2
+ (package
+ (inherit go-github-com-pion-transport)
+ (name "go-github-com-pion-transport-v2")
+ (version "2.2.5")
+ (source
+ (origin
+ (inherit (package-source go-github-com-pion-transport))
+ (uri (git-reference
+ (url "https://github.com/pion/transport/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00q3v37l56yr1ch25g5w70jy8y923csbvy4krvy4dv3h5f1mdpmf"))))
+ (arguments
+ (list
+ #:import-path "github.com/pion/transport/v2"))))
+
(define-public go-github-com-pires-go-proxyproto
(package
(name "go-github-com-pires-go-proxyproto")