aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 22:09:24 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 23:07:39 +0100
commit08f391af7839a935d746ae7fdd4bb66666c90f28 (patch)
tree620c23e20aea61ed2bd001b8e98ed138b3979473 /gnu/packages/golang-web.scm
parent26b324d08279a1d04d8f19fd569822c9e15356ab (diff)
downloadguix-08f391af7839a935d746ae7fdd4bb66666c90f28.tar
guix-08f391af7839a935d746ae7fdd4bb66666c90f28.tar.gz
gnu: Add go-github-com-pion-transport.
* gnu/packages/golang-web.scm (go-github-com-pion-transport): New variable. Change-Id: If8b5a965d1660b511058972e367566bcc2c83aa3
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 013ab933c8..8c8f176964 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1615,6 +1615,41 @@ which produce colorized output using github.com/fatih/color.")
packetizer and depacketizer.")
(license license:expat)))
+(define-public go-github-com-pion-transport
+ (package
+ (name "go-github-com-pion-transport")
+ (version "0.14.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/transport")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0331kywqaa6fymc64wrqgwnxlhx31qdf299i927vifx1wdcl9ikp"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Source-only package
+ #:tests? #f
+ #:import-path "github.com/pion/transport"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-pion-logging
+ go-golang-org-x-net
+ go-golang-org-x-sys))
+ (home-page "https://github.com/pion/transport")
+ (synopsis "Golang networking related functions")
+ (description
+ "This package implements a various networking related functions used
+throughout the @url{https://github.com/pion, Pion} modules.")
+ (license license:expat)))
+
(define-public go-github-com-pires-go-proxyproto
(package
(name "go-github-com-pires-go-proxyproto")