aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-16 22:31:43 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-19 23:46:41 +0100
commit369b5274d902df03cd55348a83e581ccd5a6a918 (patch)
tree8119b1026196831a4a1bf9732e97ae2bd7660436 /gnu/packages/gnome-xyz.scm
parent47cb05757d64777bc34b9fd776f3ab069d5857fd (diff)
downloadguix-369b5274d902df03cd55348a83e581ccd5a6a918.tar
guix-369b5274d902df03cd55348a83e581ccd5a6a918.tar.gz
gnu: gnome-shell-extension-dash-to-panel: Update to 56.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-panel): Update to 56. [arguments]: Convert to list of G-Expressions. [native-inputs]: Add `(,glib "bin"). [propagated-inputs]: Remove `(,glib "bin"). Change-Id: I24a83766b750feb1004bbaf2f5badc9e21f1c30e Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index c32dd3f3ee..d8be063846 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -953,7 +953,7 @@ certain elements or change animation speeds.")
(define-public gnome-shell-extension-dash-to-panel
(package
(name "gnome-shell-extension-dash-to-panel")
- (version "56")
+ (version "56") ;Compatible with GNOME 44
(source (origin
(method git-fetch)
(uri (git-reference
@@ -965,22 +965,24 @@ certain elements or change animation speeds.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
- #:make-flags (list (string-append "INSTALLBASE="
- (assoc-ref %outputs "out")
- "/share/gnome-shell/extensions")
- (string-append "VERSION="
- ,(package-version
- gnome-shell-extension-dash-to-panel)))
+ (list
+ #:tests? #f
+ #:make-flags #~(list (string-append "INSTALLBASE="
+ #$output
+ "/share/gnome-shell/extensions")
+ (string-append "VERSION="
+ #$version))
#:phases
- (modify-phases %standard-phases
- (delete 'bootstrap)
- (delete 'configure))))
+ #~(modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure))))
(native-inputs
- (list intltool pkg-config))
+ (list
+ `(,glib "bin")
+ intltool
+ pkg-config))
(propagated-inputs
- (list glib
- `(,glib "bin")))
+ (list glib))
(synopsis "Icon taskbar for GNOME Shell")
(description "This extension moves the dash into the gnome main
panel so that the application launchers and system tray are combined