aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-16 22:30:13 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-19 23:46:41 +0100
commit47cb05757d64777bc34b9fd776f3ab069d5857fd (patch)
treeeb8d8338ea287efba8eaba47b222ed2e7181d51b /gnu/packages/gnome-xyz.scm
parent17c2e26068c5c36eb8ee1ec39a8695ef66f75c55 (diff)
downloadguix-47cb05757d64777bc34b9fd776f3ab069d5857fd.tar
guix-47cb05757d64777bc34b9fd776f3ab069d5857fd.tar.gz
gnu: gnome-shell-extension-dash-to-dock: Update to 79.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-dock): Update to 79. [arguments]: Convert to list of G-Expressions. [native-inputs]: Drop labels. Change-Id: I327027d8a0ffc2bc7d234fe6517724fd218b947c Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a49442bdbe..c32dd3f3ee 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -722,7 +722,7 @@ easier to keep track of applications running in the background.")
(define-public gnome-shell-extension-dash-to-dock
(package
(name "gnome-shell-extension-dash-to-dock")
- (version "73")
+ (version "79")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -731,23 +731,25 @@ easier to keep track of applications running in the background.")
version))))
(sha256
(base32
- "1l0isbrgfc8v46l1yc5l4myz7qnlxzyfyiifipp86z9d79d8klzw"))
+ "0fsfhgpg8441x28jzhjspb9i9c5502c2fcgdvfggcsmz0sf3v95y"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f
- #:make-flags (list (string-append "INSTALLBASE="
- (assoc-ref %outputs "out")
- "/share/gnome-shell/extensions"))
- #:phases
- (modify-phases %standard-phases
- (delete 'bootstrap)
- (delete 'configure))))
+ (list
+ #:tests? #f
+ #:make-flags #~(list (string-append "INSTALLBASE="
+ #$output
+ "/share/gnome-shell/extensions"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure))))
(native-inputs
- `(("glib:bin" ,glib "bin")
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("sassc" ,sassc)))
+ (list
+ `(,glib "bin")
+ intltool
+ pkg-config
+ sassc))
(propagated-inputs
(list glib))
(synopsis "Transforms GNOME's dash into a dock")