aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-01 02:00:00 +0200
commitd68dfe6c96f139492fad23dd9b2dffe0218e880c (patch)
treeebf701d84a7b0c930da95cccc1615ab4cbcb8a5a /gnu/packages/file-systems.scm
parenta1aed6f159f661629ffe3530f3e6b2c344df219f (diff)
downloadguix-d68dfe6c96f139492fad23dd9b2dffe0218e880c.tar
guix-d68dfe6c96f139492fad23dd9b2dffe0218e880c.tar.gz
gnu: bcachefs-static: Don't rely on input labels.
* gnu/packages/file-systems.scm (bcachefs/static)[arguments]: Substitute SEARCH-INPUT-FILE for THIS-PACKAGE-INPUT. Change-Id: I5ee816c2380b291a3f968139d33a40755c715ad3
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index c40c30f5b3..c1342706fa 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -723,14 +723,10 @@ performance and other characteristics.")
#:builder
#~(begin
(use-modules (guix build utils))
- (mkdir-p #$output)
- (with-directory-excursion #$output
- (install-file (string-append #$(this-package-input
- "bcachefs-tools-static")
- "/sbin/bcachefs")
- "sbin")
- (remove-store-references "sbin/bcachefs")
- (invoke "sbin/bcachefs" "version"))))) ; test suite
+ (let ((target (string-append #$output "/sbin/bcachefs")))
+ (install-file (search-input-file %build-inputs "sbin/bcachefs")
+ (dirname target))
+ (remove-store-references target)))))
(inputs
(list bcachefs-tools/static))
(home-page (package-home-page bcachefs-tools/static))